ibus-cangjie-2.3.ebuild 1.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python3_4 )
  5. inherit autotools-utils gnome2-utils python-r1 eutils
  6. DESCRIPTION="The IBus engine for users of the Cangjie and Quick input methods"
  7. HOMEPAGE="http://cangjians.github.io"
  8. SRC_URI="https://github.com/Cangjians/ibus-cangjie/releases/download/v${PV}/ibus-cangjie-${PV}.tar.xz"
  9. LICENSE="GPL-3+"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. DEPEND="${PYTHON_DEPS}
  13. >=app-i18n/ibus-1.4.1
  14. app-i18n/libcangjie
  15. dev-python/cangjie[${PYTHON_USEDEP}]
  16. dev-util/intltool
  17. sys-devel/gettext"
  18. RDEPEND=">=app-i18n/ibus-1.4.1
  19. app-i18n/libcangjie
  20. dev-python/cangjie[${PYTHON_USEDEP}]
  21. virtual/libintl
  22. ${PYTHON_DEPS}"
  23. src_configure() {
  24. python_foreach_impl autotools-utils_src_configure
  25. }
  26. src_compile() {
  27. python_foreach_impl autotools-utils_src_compile
  28. }
  29. src_install() {
  30. python_foreach_impl autotools-utils_src_install
  31. }
  32. pkg_preinst() {
  33. gnome2_icon_savelist
  34. }
  35. pkg_postinst() {
  36. gnome2_icon_cache_update
  37. }