ibus-pinyin-1.5.0-r2.ebuild 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. PYTHON_REQ_USE="sqlite"
  6. inherit python-single-r1 eutils
  7. DESCRIPTION="Chinese PinYin IMEngine for IBus Framework"
  8. HOMEPAGE="https://github.com/ibus/ibus/wiki"
  9. SRC_URI="https://ibus.googlecode.com/files/${P}.tar.gz"
  10. LICENSE="GPL-2"
  11. SLOT="0"
  12. KEYWORDS="amd64 x86"
  13. IUSE="boost lua nls"
  14. RDEPEND="${PYTHON_DEPS}
  15. >=app-i18n/ibus-1.4[python,${PYTHON_USEDEP}]
  16. dev-python/pygtk[${PYTHON_USEDEP}]
  17. app-i18n/pyzy
  18. boost? ( >=dev-libs/boost-1.39 )
  19. lua? (
  20. >=dev-lang/lua-5.1
  21. <dev-lang/lua-5.2 )
  22. nls? ( virtual/libintl )"
  23. DEPEND="${RDEPEND}
  24. sys-apps/sed
  25. virtual/pkgconfig
  26. nls? ( >=sys-devel/gettext-0.16.1 )"
  27. REQUIRED_USE=${PYTHON_REQUIRED_USE}
  28. DOCS="AUTHORS ChangeLog NEWS README"
  29. src_prepare() {
  30. sed -i -e "s/python/${EPYTHON}/" setup/ibus-setup-pinyin.in || die
  31. epatch "${FILESDIR}"/${P}-content-type-method.patch
  32. }
  33. src_configure() {
  34. econf \
  35. $(use_enable boost) \
  36. $(use_enable lua lua-extension) \
  37. $(use_enable nls) \
  38. --enable-english-input-mode
  39. }