ibus-table-1.5.0-r1.ebuild 906 B

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. PYTHON_REQ_USE="sqlite"
  6. inherit eutils python-single-r1
  7. DESCRIPTION="The Table Engine for IBus Framework"
  8. HOMEPAGE="https://github.com/ibus/ibus/wiki"
  9. SRC_URI="https://ibus.googlecode.com/files/${P}.tar.gz"
  10. LICENSE="GPL-2 LGPL-2.1"
  11. SLOT="0"
  12. KEYWORDS="amd64 x86"
  13. IUSE="nls"
  14. RDEPEND="${PYTHON_DEPS}
  15. >=app-i18n/ibus-1.2[python,${PYTHON_USEDEP}]
  16. nls? ( virtual/libintl )"
  17. DEPEND="${RDEPEND}
  18. nls? ( >=sys-devel/gettext-0.16.1 )
  19. virtual/pkgconfig"
  20. REQUIRED_USE=${PYTHON_REQUIRED_USE}
  21. src_prepare() {
  22. python_fix_shebang .
  23. sed -i -e "s/python/${EPYTHON}/" \
  24. engine/ibus-table-createdb.in engine/ibus-engine-table.in || die
  25. }
  26. src_configure() {
  27. econf $(use_enable nls)
  28. }
  29. src_install() {
  30. emake DESTDIR="${D}" install
  31. dodoc AUTHORS ChangeLog NEWS README
  32. }