ibus-unikey-0.6.1.ebuild 698 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="4"
  4. inherit eutils
  5. DESCRIPTION="Vietnamese Input Method Engine for IBUS using Unikey IME"
  6. HOMEPAGE="https://code.google.com/p/ibus-unikey/"
  7. SRC_URI="https://ibus-unikey.googlecode.com/files/${P}.tar.gz"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="gtk3"
  12. RDEPEND="gtk3? ( >app-i18n/ibus-1.4.0[gtk3]
  13. x11-libs/gtk+:3 )
  14. !gtk3? ( >=app-i18n/ibus-1.4.0
  15. >=x11-libs/gtk+-2.12:2 )
  16. x11-libs/libX11"
  17. DEPEND="${RDEPEND}
  18. virtual/pkgconfig
  19. dev-util/intltool
  20. >=sys-devel/gettext-0.17"
  21. src_configure() {
  22. use gtk3 && myconf="--with-gtk-version=3" || myconf=""
  23. econf ${myconf}
  24. }