jfbterm-0.4.7-r4.ebuild 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit autotools flag-o-matic
  5. DESCRIPTION="The J Framebuffer Terminal/Multilingual Enhancement with UTF-8 support"
  6. HOMEPAGE="http://jfbterm.sourceforge.jp/"
  7. SRC_URI="mirror://sourceforge.jp/${PN}/13501/${P}.tar.gz"
  8. LICENSE="BSD"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc ppc64 sparc x86"
  11. IUSE="debug"
  12. DEPEND="sys-libs/ncurses:0"
  13. RDEPEND="
  14. media-fonts/unifont
  15. media-fonts/font-misc-misc
  16. media-fonts/intlfonts"
  17. PATCHES=(
  18. "${FILESDIR}"/${P}-sigchld-debian.patch
  19. "${FILESDIR}"/${P}-no-kernel-headers.patch
  20. "${FILESDIR}"/${P}-gentoo.patch
  21. "${FILESDIR}"/${P}-wrong-inline-gcc5.patch
  22. )
  23. src_prepare() {
  24. default
  25. mv configure.{in,ac} || die
  26. eautoreconf
  27. }
  28. src_configure() {
  29. econf $(use_enable debug)
  30. }
  31. src_install() {
  32. dodir /etc /usr/share/fonts/jfbterm
  33. default
  34. mv "${ED%/}"/etc/jfbterm.conf{.sample,} || die
  35. doman jfbterm.1 jfbterm.conf.5
  36. # install example config files
  37. docinto examples
  38. dodoc jfbterm.conf.sample*
  39. docompress -x /usr/share/doc/${PF}/examples
  40. }