kcm-fcitx-0.4.3.ebuild 941 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="6"
  4. inherit cmake-utils xdg
  5. if [[ "${PV}" =~ (^|\.)9999$ ]]; then
  6. inherit git-r3
  7. EGIT_REPO_URI="https://github.com/fcitx/kcm-fcitx"
  8. EGIT_BRANCH="kde4"
  9. fi
  10. DESCRIPTION="KDE configuration module for Fcitx"
  11. HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/kcm-fcitx"
  12. if [[ "${PV}" =~ (^|\.)9999$ ]]; then
  13. SRC_URI=""
  14. else
  15. SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
  16. fi
  17. LICENSE="GPL-2+"
  18. SLOT="4"
  19. KEYWORDS="amd64 ~ppc ~ppc64 x86"
  20. IUSE="minimal"
  21. RDEPEND=">=app-i18n/fcitx-4.2.8[dbus,qt4]
  22. dev-qt/qtcore:4
  23. dev-qt/qtdbus:4
  24. dev-qt/qtgui:4
  25. kde-frameworks/kdelibs:4
  26. virtual/libintl
  27. x11-libs/libX11
  28. x11-libs/libxkbfile"
  29. DEPEND="${RDEPEND}
  30. dev-util/automoc
  31. sys-devel/gettext
  32. virtual/pkgconfig"
  33. src_prepare() {
  34. if use minimal; then
  35. cmake_comment_add_subdirectory po
  36. fi
  37. cmake-utils_src_prepare
  38. }