libguess-1.2.ebuild 742 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. DESCRIPTION="A high-speed character set detection library"
  5. HOMEPAGE="http://www.atheme.org/project/libguess"
  6. SRC_URI="http://rabbit.dereferenced.org/~nenolod/distfiles/${P}.tar.bz2"
  7. LICENSE="BSD-2"
  8. SLOT="0"
  9. KEYWORDS="alpha amd64 arm hppa ~ia64 ppc ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
  10. IUSE="examples"
  11. RDEPEND="
  12. >=dev-libs/libmowgli-0.7.0:0"
  13. DEPEND="${RDEPEND}
  14. virtual/pkgconfig"
  15. src_configure() {
  16. econf $(use_enable examples) \
  17. || die "econf failed"
  18. }
  19. src_test() {
  20. cd src/tests
  21. make || die "test failed"
  22. }
  23. src_install() {
  24. emake DESTDIR="${D}" install || die "emake install failed"
  25. dodoc README
  26. }