librime-0.9.9.ebuild 883 B

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit cmake-utils multilib
  5. DESCRIPTION="Rime Input Method Engine library"
  6. HOMEPAGE="http://rime.im/"
  7. SRC_URI="https://rimeime.googlecode.com/files/${P}.tar.gz"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~ppc ~ppc64 x86"
  11. IUSE="static-libs test"
  12. RDEPEND="app-i18n/opencc
  13. dev-cpp/glog
  14. >=dev-cpp/yaml-cpp-0.5.0
  15. dev-db/kyotocabinet
  16. >=dev-libs/boost-1.46.0[threads(+)]
  17. sys-libs/zlib
  18. x11-proto/xproto"
  19. DEPEND="${RDEPEND}
  20. test? ( dev-cpp/gtest )"
  21. S="${WORKDIR}/${PN}"
  22. PATCHES=(
  23. "${FILESDIR}/${PN}-test.patch"
  24. "${FILESDIR}/${PN}-dictionary.patch"
  25. )
  26. src_configure() {
  27. local mycmakeargs=(
  28. $(cmake-utils_use_build static-libs STATIC)
  29. -DBUILD_DATA=OFF
  30. $(cmake-utils_use_build test TEST)
  31. -DLIB_INSTALL_DIR=/usr/$(get_libdir)
  32. )
  33. cmake-utils_src_configure
  34. }