libskk-0.0.11.ebuild 1002 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. VALA_MIN_API_VERSION=0.14
  5. inherit virtualx vala
  6. DESCRIPTION="GObject-based library to deal with Japanese kana-to-kanji conversion method"
  7. HOMEPAGE="https://github.com/ueno/libskk"
  8. SRC_URI="mirror://github/ueno/${PN}/${P}.tar.gz"
  9. LICENSE="GPL-3"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE="nls +introspection static-libs"
  13. RDEPEND=">=dev-libs/glib-2.16
  14. dev-libs/libgee:0
  15. dev-libs/json-glib
  16. introspection? ( >=dev-libs/gobject-introspection-0.10.8 )
  17. nls? ( virtual/libintl )"
  18. DEPEND="${RDEPEND}
  19. $(vala_depend)
  20. virtual/pkgconfig
  21. nls? (
  22. dev-util/intltool
  23. sys-devel/gettext
  24. )"
  25. # doc? ( >=dev-util/valadoc-0.3.1 )
  26. DOCS="ChangeLog NEWS README"
  27. src_configure() {
  28. econf \
  29. $(use_enable nls) \
  30. $(use_enable static-libs static) \
  31. $(use_enable introspection)
  32. }
  33. src_test() {
  34. Xemake check || die "emake check failed."
  35. }
  36. src_install() {
  37. default
  38. rm -f "${ED}"/usr/lib*/lib*.la
  39. }