libskk-0.0.9.ebuild 889 B

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. VALA_MIN_API_VERSION=0.12
  5. inherit vala
  6. DESCRIPTION="GObject-based library to deal with Japanese kana-to-kanji conversion method"
  7. HOMEPAGE="https://github.com/ueno/libskk"
  8. SRC_URI="mirror://github/ueno/${PN}/${P}.tar.gz"
  9. LICENSE="GPL-3"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE="nls static-libs"
  13. RDEPEND="dev-libs/glib
  14. dev-libs/libgee:0
  15. dev-libs/json-glib
  16. >=dev-libs/gobject-introspection-0.9
  17. $(vala_depend)
  18. nls? ( virtual/libintl )"
  19. # >=dev-util/valadoc-0.3.1
  20. DEPEND="${RDEPEND}
  21. virtual/pkgconfig
  22. nls? ( sys-devel/gettext )"
  23. src_configure() {
  24. econf \
  25. $(use_enable nls) \
  26. $(use_enable static-libs static)
  27. }
  28. src_install() {
  29. default
  30. if ! use static-libs ; then
  31. find "${ED}" -name '*.la' -delete
  32. fi
  33. doman docs/skk.1
  34. dodoc AUTHORS ChangeLog NEWS README
  35. }