libtomoe-gtk-0.6.0-r4.ebuild 1.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit python-single-r1
  6. MY_P="tomoe-gtk-${PV}"
  7. DESCRIPTION="Tomoe GTK+ interface widget library"
  8. HOMEPAGE="http://tomoe.sourceforge.jp/"
  9. SRC_URI="mirror://sourceforge/tomoe/${MY_P}.tar.gz"
  10. LICENSE="LGPL-2.1"
  11. SLOT="0"
  12. KEYWORDS="amd64 ~x86"
  13. IUSE="python static-libs"
  14. REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
  15. RDEPEND="
  16. >=app-i18n/tomoe-0.6.0
  17. python? (
  18. ${PYTHON_DEPS}
  19. >=app-i18n/tomoe-0.6.0[python,${PYTHON_USEDEP}]
  20. dev-python/pygtk:2[${PYTHON_USEDEP}]
  21. dev-python/pygobject:2[${PYTHON_USEDEP}]
  22. )
  23. "
  24. DEPEND="${RDEPEND}
  25. dev-util/gtk-doc-am
  26. virtual/pkgconfig
  27. sys-devel/gettext
  28. "
  29. S="${WORKDIR}/${MY_P}"
  30. pkg_setup() {
  31. if use python ; then
  32. python-single-r1_pkg_setup
  33. fi
  34. }
  35. src_configure() {
  36. local myconf
  37. #--with-python b0rked hard
  38. unset PYTHON
  39. use python || myconf="${myconf} --without-python"
  40. # Rely on precompiled gtk-doc files,
  41. # https://wiki.gentoo.org/wiki/Project:GNOME/Gnome_Team_Ebuild_Policies#gtk-doc
  42. econf \
  43. --disable-gtk-doc \
  44. --without-gucharmap \
  45. $(use_enable static-libs static) \
  46. ${myconf}
  47. }
  48. src_install() {
  49. default
  50. if use python ; then
  51. find "${D}$(python_get_sitedir)" \( -name "*.la" -o -name "*.a" \) -type f -delete || die
  52. fi
  53. if ! use static-libs ; then
  54. find "${ED}" -name "*.la" -type f -delete || die
  55. fi
  56. }