man-pages-pl-0_pre20070628-r2.ebuild 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit autotools
  5. DESCRIPTION="A collection of Polish translations of Linux manual pages"
  6. HOMEPAGE="http://www.batnet.pl/ptm/"
  7. SRC_URI="http://www.batnet.pl/ptm/man-PL28-06-2007.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
  11. IUSE=""
  12. RDEPEND=""
  13. DEPEND=""
  14. DOCS=(AUTHORS ChangeLog FAQ NEWS README TODO)
  15. S="${WORKDIR}/pl_PL"
  16. src_prepare() {
  17. # missing manpages
  18. sed -i -e '/\tpasswd.1/ d' man1/Makefile.am || die
  19. # manpages provided by other packages
  20. mans="gendiff.1 groups.1 apropos.1 man.1 su.1 newgrp.1 whatis.1 gpasswd.1 chsh.1 \
  21. chfn.1 limits.5 login.1 expiry.1 porttime.5 lastlog.8 faillog.8 logoutd.8 \
  22. rpm.8 rpmdeps.8 rpmbuild.8 rpmcache.8 rpmgraph.8 rpm2cpio.8 evim.1 vim.1 \
  23. vimdiff.1 vimtutor.1 ex.1 rview.1 rvim.1 view.1 suauth.5 mc.1"
  24. # bug #375623:
  25. mans="${mans} manpath.5 catman.8 mandb.8 zsoelim.1 manpath.1"
  26. # bug #403379:
  27. mans="${mans} shadow.3"
  28. for page in ${mans} ; do
  29. sed -i -e "/\\t${page}/d; \$s,\\\,,;" man${page: -1}/Makefile.am || die
  30. done
  31. eautoreconf
  32. }