scim-anthy-1.2.7-r1.ebuild 1.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools eutils
  5. DESCRIPTION="Japanese input method Anthy IMEngine for SCIM"
  6. HOMEPAGE="http://scim-imengine.sourceforge.jp/index.cgi?cmd=view;name=SCIMAnthy"
  7. SRC_URI="mirror://sourceforge.jp/scim-imengine/37309/${P}.tar.gz
  8. gtk3? ( https://dev.gentoo.org/~heroxbd/${P}-patches.tar.xz )"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="alpha amd64 ~arm ppc sparc x86 ~x86-fbsd"
  12. IUSE="+gtk3 nls kasumi"
  13. DEPEND=">=app-i18n/scim-1.2[gtk3=]
  14. >=app-i18n/anthy-5900
  15. nls? ( virtual/libintl )
  16. gtk3? ( x11-libs/gtk+:3 )"
  17. RDEPEND="${DEPEND}
  18. kasumi? ( app-dicts/kasumi )"
  19. DEPEND="${DEPEND}
  20. nls? ( sys-devel/gettext )
  21. virtual/pkgconfig"
  22. src_prepare() {
  23. if use gtk3; then
  24. EPATCH_SOURCE="${WORKDIR}/patches" EPATCH_SUFFIX="patch" epatch
  25. fi
  26. eautoreconf
  27. }
  28. src_configure() {
  29. econf \
  30. $(use_enable nls) \
  31. --disable-static \
  32. --disable-dependency-tracking
  33. }
  34. src_install() {
  35. default
  36. dodoc AUTHORS ChangeLog NEWS README
  37. }