scim-tables-0.5.13.ebuild 1.5 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit autotools base eutils
  4. DESCRIPTION="Smart Common Input Method (SCIM) Generic Table Input Method Server"
  5. HOMEPAGE="http://www.scim-im.org/"
  6. SRC_URI="mirror://sourceforge/scim/${P}.tar.gz"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="amd64 ~arm ppc x86"
  10. IUSE="nls"
  11. LANGS="am ar bn gu hi ja kn ko ml ne pa ru ta te th uk vi zh"
  12. for i in ${LANGS} ; do
  13. IUSE="${IUSE} linguas_${i}"
  14. done
  15. RDEPEND=">=app-i18n/scim-1.4.7-r2
  16. nls? ( virtual/libintl )"
  17. DEPEND="${RDEPEND}
  18. virtual/pkgconfig
  19. nls? ( sys-devel/gettext )"
  20. PATCHES=(
  21. "${FILESDIR}/${PN}-0.5.8+gcc-4.3.patch"
  22. "${FILESDIR}"/${PN}-0.5.12-automake.patch
  23. )
  24. pkg_setup() {
  25. elog "Not all languages are going to be compiled."
  26. elog "Please set LINGUAS to your preferred language(s)."
  27. elog "Supported LINGUAS values are:"
  28. elog "${LANGS}"
  29. }
  30. src_unpack() {
  31. base_src_unpack
  32. strip-linguas ${LANGS}
  33. local use_languages="additional ${LINGUAS}"
  34. elog "Languages being compiled are: ${use_languages}"
  35. cd "${S}"
  36. sed -i -e "/^SUBDIRS/s/.*/SUBDIRS = ${use_languages}/g" \
  37. tables/Makefile.{am,in} || die "sed ${m} failed"
  38. AT_NO_RECURSIVE=yes AT_M4DIR=${S}/m4 eautoreconf
  39. }
  40. src_compile() {
  41. econf \
  42. --disable-skim-support \
  43. $(use_enable nls) \
  44. --disable-static \
  45. --disable-dependency-tracking \
  46. --without-arts || die "econf failed"
  47. emake || die "make failed"
  48. }
  49. src_install() {
  50. emake DESTDIR="${D}" install || die "install failed"
  51. dodoc README ChangeLog AUTHORS
  52. }