sunpinyin-data-20121025.ebuild 910 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. DICT_VERSION="20120830"
  5. LM_VERSION="${PV}"
  6. DESCRIPTION="Data sets for Sunpinyin"
  7. HOMEPAGE="https://open-gram.googlecode.com/"
  8. SRC_URI="https://open-gram.googlecode.com/files/dict.utf8-${DICT_VERSION}.tar.bz2
  9. https://open-gram.googlecode.com/files/lm_sc.t3g.arpa-${LM_VERSION}.tar.bz2"
  10. LICENSE="Apache-2.0"
  11. SLOT="0"
  12. KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
  13. IUSE=""
  14. DEPEND=">=app-i18n/sunpinyin-2.0.4_pre20130108"
  15. RDEPEND="${DEPEND}"
  16. src_unpack() {
  17. default
  18. mkdir "${S}" || die
  19. mv "${WORKDIR}"/dict.utf8 "${S}" || die
  20. mv "${WORKDIR}"/lm_sc.t3g.arpa "${S}" || die
  21. cp "${FILESDIR}"/SLM-inst.mk "${S}"/Makefile || die
  22. }
  23. src_compile() {
  24. # we don't have any big-endian architectures keyworded yet, so hardcode
  25. emake ENDIANNESS=le
  26. }
  27. src_install() {
  28. emake ENDIANNESS=le DESTDIR="${D}" install
  29. }