uchardet-0.0.5-r1.ebuild 847 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit cmake-utils
  5. DESCRIPTION="An encoding detector library"
  6. HOMEPAGE="https://github.com/BYVoid/uchardet https://www.freedesktop.org/wiki/Software/uchardet/"
  7. SRC_URI="https://github.com/BYVoid/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="|| ( MPL-1.1 GPL-2+ LGPL-2.1+ )"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 ~arm hppa ppc64 x86"
  11. IUSE="static-libs test"
  12. PATCHES=(
  13. "${FILESDIR}/${P}-fix-ASCII-detection.patch"
  14. "${FILESDIR}/${P}-use-proper-package-name.patch"
  15. "${FILESDIR}/${P}-fix-return-code-on-error.patch"
  16. )
  17. src_prepare() {
  18. use test || cmake_comment_add_subdirectory test
  19. cmake-utils_src_prepare
  20. }
  21. src_configure() {
  22. local mycmakeargs=(
  23. $(cmake-utils_use_build static-libs STATIC)
  24. )
  25. cmake-utils_src_configure
  26. }