uchardet-0.0.6.ebuild 643 B

12345678910111213141516171819202122232425262728
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit cmake-utils
  5. DESCRIPTION="An encoding detector library"
  6. HOMEPAGE="https://www.freedesktop.org/wiki/Software/uchardet/"
  7. SRC_URI="https://www.freedesktop.org/software/${PN}/releases/${P}.tar.xz"
  8. LICENSE="|| ( MPL-1.1 GPL-2+ LGPL-2.1+ )"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 ~arm ~hppa ppc ppc64 x86"
  11. IUSE="static-libs test"
  12. src_prepare() {
  13. cmake-utils_src_prepare
  14. use test || cmake_comment_add_subdirectory test
  15. }
  16. src_configure() {
  17. local mycmakeargs=(
  18. -DBUILD_STATIC=$(usex static-libs)
  19. )
  20. cmake-utils_src_configure
  21. }