uchardet-9999.ebuild 654 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit cmake-utils git-r3
  5. DESCRIPTION="An encoding detector library"
  6. HOMEPAGE="https://www.freedesktop.org/wiki/Software/uchardet/"
  7. EGIT_REPO_URI=(
  8. https://anongit.freedesktop.org/git/${PN}/${PN}.git
  9. git://anongit.freedesktop.org/${PN}/${PN}
  10. )
  11. LICENSE="|| ( MPL-1.1 GPL-2+ LGPL-2.1+ )"
  12. SLOT="0"
  13. KEYWORDS=""
  14. IUSE="static-libs test"
  15. src_prepare() {
  16. cmake-utils_src_prepare
  17. use test || cmake_comment_add_subdirectory test
  18. }
  19. src_configure() {
  20. local mycmakeargs=(
  21. -DBUILD_STATIC=$(usex static-libs)
  22. )
  23. cmake-utils_src_configure
  24. }