mbpfan-1.9.1.ebuild 766 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit linux-info systemd toolchain-funcs
  5. DESCRIPTION="A simple daemon to control fan speed on all Macbook/Macbook Pros"
  6. HOMEPAGE="https://github.com/dgraziotin/mbpfan"
  7. SRC_URI="https://github.com/dgraziotin/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="GPL-3+"
  9. SLOT="0"
  10. KEYWORDS="~amd64"
  11. RESTRICT="test" # will fail if the hardware is unavailable, not useful
  12. CONFIG_CHECK="~SENSORS_APPLESMC ~SENSORS_CORETEMP"
  13. src_prepare() {
  14. sed -i -e "s:g++:$(tc-getCXX):g" Makefile || die
  15. default
  16. }
  17. src_install() {
  18. dosbin bin/mbpfan
  19. insinto /etc
  20. doins ${PN}.conf
  21. newinitd ${PN}.init.gentoo ${PN}
  22. systemd_dounit ${PN}.service
  23. einstalldocs
  24. }