nvidiabl-0.83.ebuild 871 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit linux-mod
  5. DESCRIPTION="Linux driver for setting the backlight brightness on laptops using
  6. NVIDIA GPU"
  7. HOMEPAGE="https://github.com/guillaumezin/nvidiabl"
  8. SRC_URI="https://github.com/guillaumezin/${PN}/archive/v${PV}.tar.gz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="amd64 x86"
  12. IUSE=""
  13. DEPEND=""
  14. RDEPEND=""
  15. RESTRICT="test"
  16. BUILD_TARGETS="modules"
  17. MODULE_NAMES="nvidiabl()"
  18. pkg_pretend() {
  19. CONFIG_CHECK="FB_BACKLIGHT"
  20. ERROR_FB_BACKLIGHT="Your kernel does not support FB_BACKLIGHT. To enable you
  21. it you can enable any frame buffer with backlight control or nouveau.
  22. Note that you cannot use FB_NVIDIA with nvidia's proprietary driver"
  23. linux-mod_pkg_setup
  24. }
  25. src_compile() {
  26. BUILD_PARAMS="KVER=${KV_FULL}"
  27. MAKEOPTS+=" V=1"
  28. linux-mod_src_compile
  29. }