nvidiabl-0.87.ebuild 910 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit linux-mod eutils
  5. DESCRIPTION="Linux driver for setting the backlight brightness on laptops using NVIDIA GPU"
  6. HOMEPAGE="https://github.com/guillaumezin/nvidiabl"
  7. SRC_URI="https://github.com/guillaumezin/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. pkg_setup() {
  12. CONFIG_CHECK="FB_BACKLIGHT"
  13. ERROR_FB_BACKLIGHT="Your kernel does not support FB_BACKLIGHT. To enable you
  14. it you can enable any frame buffer with backlight control or nouveau.
  15. Note that you cannot use FB_NVIDIA with nvidia's proprietary driver"
  16. linux-mod_pkg_setup
  17. }
  18. src_prepare() {
  19. epatch "${FILESDIR}"/${P}-linux-4.0.patch
  20. }
  21. src_compile() {
  22. BUILD_PARAMS="KVER=${KV_FULL}"
  23. BUILD_TARGETS="modules"
  24. MODULE_NAMES="nvidiabl()"
  25. MAKEOPTS+=" V=1"
  26. linux-mod_src_compile
  27. }