plan-1.10.ebuild 1.4 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils
  5. DESCRIPTION="Motif based schedule planner"
  6. HOMEPAGE="http://www.bitrot.de/plan.html"
  7. SRC_URI="ftp://ftp.fu-berlin.de/unix/X11/apps/plan/${P}.tar.gz
  8. mirror://gentoo/${P}-gentoo.tar.xz"
  9. LICENSE="GPL-2+" #448646
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
  12. IUSE=""
  13. DEPEND="
  14. x11-libs/libXpm
  15. >=x11-libs/motif-2.3:0
  16. "
  17. RDEPEND="${DEPEND}"
  18. QA_PRESTRIPPED="
  19. /usr/bin/netplan
  20. /usr/bin/plan
  21. "
  22. src_prepare() {
  23. epatch "${WORKDIR}"/${P}-patches/*.patch
  24. }
  25. src_compile() {
  26. pushd src
  27. emake CC=$(tc-getCC) SHARE=/usr/share/plan linux
  28. popd
  29. }
  30. src_install() {
  31. pushd src
  32. emake \
  33. DESTDIR="${D}" \
  34. SHARE=/usr/share/plan \
  35. install
  36. keepdir /usr/share/plan/netplan.dir
  37. popd
  38. dodoc HISTORY README
  39. pushd misc
  40. doman netplan.1 plan.1 plan.4
  41. insinto /usr/share/${PN}/misc
  42. doins netplan.boot BlackWhite Monochrome plan.fti Plan.xpm plan.xpm
  43. exeinto /usr/share/${PN}/misc
  44. doexe Killpland cvs vsc msschedule2plan plan2vcs
  45. popd
  46. pushd web
  47. insinto /usr/share/${PN}/web
  48. doins help.html bottom.html cgi-lib.pl common.pl holiday_webplan rtsban.jpg
  49. exeinto /usr/share/${PN}/web
  50. doexe *.cgi
  51. popd
  52. }
  53. pkg_postinst() {
  54. elog
  55. elog " Check /usr/share/${PN}/holiday for examples to set your"
  56. elog " ~/.holiday according to your country."
  57. elog
  58. elog " WebPlan ${PV} can be found in /usr/share/${PN}/web."
  59. elog
  60. }