qcharselect-0.3.ebuild 865 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit multilib
  5. DESCRIPTION="A Qt4 port of KCharSelect from KDE 3.5"
  6. HOMEPAGE="http://qcharselect.sourceforge.net/"
  7. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="debug"
  12. RDEPEND="dev-qt/qtgui:4[qt3support]"
  13. DEPEND="$RDEPEND
  14. x11-misc/makedepend"
  15. src_prepare() {
  16. sed -e 's:update-mime-database:true:g' \
  17. -e 's:data/desktop/qcharselect:src/QCharSelect:' \
  18. -i Makefile.in || die
  19. sed -e 's: %m::' \
  20. -e '/Path=/d' \
  21. -i src/QCharSelect.desktop || die
  22. }
  23. src_configure() {
  24. local myconf
  25. use debug && myconf="--enable-debug"
  26. econf \
  27. --with-qtdir=/usr \
  28. --with-qtlibdir=/usr/$(get_libdir)/qt4 \
  29. ${myconf}
  30. }
  31. src_install() {
  32. emake DESTDIR="${D}" install || die
  33. dodoc README
  34. }