libusbmuxd-1.0.9.ebuild 887 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools-utils
  5. DESCRIPTION="USB multiplex daemon for use with Apple iPhone/iPod Touch devices"
  6. HOMEPAGE="http://www.libimobiledevice.org/"
  7. SRC_URI="http://www.libimobiledevice.org/downloads/${P}.tar.bz2"
  8. # tools/iproxy.c is GPL-2+, everything else is LGPL-2.1+
  9. LICENSE="GPL-2+ LGPL-2.1+"
  10. SLOT="0/2" # based on SONAME of libusbmuxd.so
  11. KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86"
  12. IUSE="kernel_linux static-libs"
  13. RDEPEND=">=app-pda/libplist-1.11:=
  14. virtual/libusb:1
  15. !=app-pda/usbmuxd-1.0.9
  16. !<app-pda/usbmuxd-1.0.8_p1"
  17. DEPEND="${RDEPEND}
  18. virtual/os-headers
  19. virtual/pkgconfig"
  20. DOCS=( AUTHORS README )
  21. src_configure() {
  22. local myeconfargs=( $(use_enable static-libs static) )
  23. use kernel_linux || myeconfargs+=( --without-inotify )
  24. autotools-utils_src_configure
  25. }