usbmuxd-1.0.8_p20140530.ebuild 869 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. AUTOTOOLS_AUTORECONF=1
  5. inherit autotools-utils udev user
  6. DESCRIPTION="USB multiplex daemon for use with Apple iPhone/iPod Touch devices"
  7. HOMEPAGE="http://www.libimobiledevice.org/"
  8. #SRC_URI="http://www.libimobiledevice.org/downloads/${P}.tar.bz2"
  9. SRC_URI="https://dev.gentoo.org/~ssuominen/${P}.tar.xz"
  10. # src/utils.h is LGPL-2.1+, rest is found in COPYING*
  11. LICENSE="GPL-2 GPL-3 LGPL-2.1+"
  12. SLOT="0"
  13. KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86"
  14. IUSE=""
  15. RDEPEND=">=app-pda/libimobiledevice-1.1.6
  16. >=app-pda/libplist-1.11
  17. virtual/libusb:1"
  18. DEPEND="${RDEPEND}
  19. virtual/os-headers
  20. virtual/pkgconfig"
  21. pkg_setup() {
  22. enewgroup plugdev
  23. enewuser usbmux -1 -1 -1 "usb,plugdev"
  24. }
  25. src_install() {
  26. autotools-utils_src_install udevrulesdir="$(get_udevdir)"/rules.d
  27. }