fish-2.4.0.ebuild 1.8 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
  5. DESCRIPTION="fish is the Friendly Interactive SHell"
  6. HOMEPAGE="http://fishshell.com/"
  7. SRC_URI="http://fishshell.com/files/${PV}/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
  11. IUSE="X"
  12. DEPEND="sys-libs/ncurses:0=
  13. sys-devel/bc
  14. sys-devel/gettext
  15. X? ( x11-misc/xsel )"
  16. RDEPEND="${DEPEND}"
  17. src_configure() {
  18. # Set things up for fish to be a default shell.
  19. # It has to be in /bin in case /usr is unavailable.
  20. # Also, all of its utilities have to be in /bin.
  21. econf \
  22. docdir="${EPREFIX}"/usr/share/doc/${PF} \
  23. --bindir="${EPREFIX}"/bin
  24. }
  25. src_test() {
  26. if has_version ~${CATEGORY}/${P} ; then
  27. emake test
  28. else
  29. ewarn "The test suite only works when the package is already installed"
  30. fi
  31. }
  32. pkg_postinst() {
  33. elog "fish is now installed on your system."
  34. elog "To run fish, type 'fish' in your terminal."
  35. elog
  36. elog "To use fish as your login shell:"
  37. elog "* add the line '${EPREFIX}/bin/${PN}'"
  38. elog "* to the file '${EPREFIX}/etc/shells'."
  39. elog "* use the command 'chsh -s ${EPREFIX}/bin/${PN}'."
  40. elog
  41. elog "To set your colors, run 'fish_config'"
  42. elog "To scan your man pages for completions, run 'fish_update_completions'"
  43. elog "To autocomplete command suggestions press Ctrl + F or right arrow key."
  44. elog
  45. elog "Please add a \"BROWSER\" variable to ${PN}'s environment pointing to the"
  46. elog "browser of your choice to get acces to ${PN}'s help system:"
  47. elog " BROWSER=\"/usr/bin/firefox\""
  48. elog
  49. elog "In order to get lzma and xz support for man-page completion please"
  50. elog "emerge one of the following packages:"
  51. elog " dev-python/backports-lzma"
  52. elog " >=dev-lang/python-3.3"
  53. elog
  54. elog "Have fun!"
  55. }