psh-1.8.1-r3.ebuild 838 B

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. DIST_EXAMPLES=( "examples/*" )
  5. inherit perl-module
  6. DESCRIPTION="Combines the interactive nature of a Unix shell with the power of Perl"
  7. HOMEPAGE="https://gnp.github.io/psh/"
  8. SRC_URI="https://github.com/gnp/psh/archive/${P}.tar.gz -> ${PF}.tar.gz"
  9. S="${WORKDIR}/${PN}-${P}" # github--
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~ppc ~x86"
  12. IUSE="readline"
  13. RDEPEND="
  14. readline? (
  15. dev-perl/Term-ReadLine-Gnu
  16. dev-perl/TermReadKey
  17. )
  18. "
  19. DEPEND="${RDEPEND}
  20. virtual/perl-ExtUtils-MakeMaker
  21. "
  22. myinst="SITEPREFIX=${D}/usr"
  23. PATCHES=(
  24. "${FILESDIR}/${PF}-defined-array.patch"
  25. "${FILESDIR}/${PF}-array-ref-deprecated.patch"
  26. )
  27. src_install() {
  28. perl-module_src_install
  29. docompress -x "/usr/share/doc/${PF}/pod"
  30. docinto pod/
  31. dodoc -r doc/*
  32. }