gtkmm-2.24.5.ebuild 1.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit gnome2 multilib-minimal
  5. DESCRIPTION="C++ interface for GTK+"
  6. HOMEPAGE="http://www.gtkmm.org"
  7. LICENSE="LGPL-2.1+"
  8. SLOT="2.4"
  9. KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
  10. IUSE="doc examples test"
  11. COMMON_DEPEND="
  12. >=dev-cpp/glibmm-2.34.1:2[${MULTILIB_USEDEP}]
  13. >=x11-libs/gtk+-2.24.15:2[${MULTILIB_USEDEP}]
  14. >=x11-libs/gdk-pixbuf-2.28:2[${MULTILIB_USEDEP}]
  15. >=dev-cpp/atkmm-2.22.7[${MULTILIB_USEDEP}]
  16. >=dev-cpp/cairomm-1.10.0-r1[${MULTILIB_USEDEP}]
  17. >=dev-cpp/pangomm-2.34.0:1.4[${MULTILIB_USEDEP}]
  18. >=dev-libs/libsigc++-2.3.2:2[${MULTILIB_USEDEP}]
  19. "
  20. RDEPEND="${COMMON_DEPEND}
  21. abi_x86_32? (
  22. !<=app-emulation/emul-linux-x86-gtkmmlibs-20140508
  23. !app-emulation/emul-linux-x86-gtkmmlibs[-abi_x86_32(-)] )
  24. "
  25. DEPEND="${COMMON_DEPEND}
  26. virtual/pkgconfig[${MULTILIB_USEDEP}]
  27. doc? (
  28. media-gfx/graphviz
  29. dev-libs/libxslt
  30. app-doc/doxygen )
  31. "
  32. src_prepare() {
  33. if ! use test; then
  34. # don't waste time building tests
  35. sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
  36. || die "sed 1 failed"
  37. fi
  38. if ! use examples; then
  39. # don't waste time building tests
  40. sed 's/^\(SUBDIRS =.*\)demos\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
  41. || die "sed 2 failed"
  42. fi
  43. gnome2_src_prepare
  44. }
  45. multilib_src_configure() {
  46. ECONF_SOURCE="${S}" \
  47. gnome2_src_configure \
  48. --enable-api-atkmm \
  49. $(multilib_native_use_enable doc documentation)
  50. }
  51. multilib_src_install() {
  52. gnome2_src_install
  53. }
  54. multilib_src_install_all() {
  55. DOCS="AUTHORS ChangeLog PORTING NEWS README"
  56. einstalldocs
  57. }