libmcpp-2.7.2-r2.ebuild 716 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit autotools
  5. MY_P=${P/lib/}
  6. DESCRIPTION="A portable C++ preprocessor"
  7. HOMEPAGE="http://mcpp.sourceforge.net"
  8. SRC_URI="mirror://sourceforge/mcpp/${MY_P}.tar.gz"
  9. LICENSE="BSD"
  10. SLOT="0"
  11. KEYWORDS="amd64 ~arm ~ia64 x86 ~x86-linux ~x64-macos"
  12. IUSE="static-libs"
  13. DEPEND=""
  14. RDEPEND=""
  15. S=${WORKDIR}/${MY_P}
  16. PATCHES=( "${FILESDIR}"/${PN}-2.7.2-fix-build-system.patch )
  17. src_prepare() {
  18. default
  19. eautoreconf
  20. }
  21. src_configure() {
  22. econf \
  23. --enable-mcpplib \
  24. $(use_enable static-libs static)
  25. }
  26. src_install() {
  27. default
  28. if ! use static-libs; then
  29. find "${D}" -name '*.la' -delete || die
  30. fi
  31. }