libxmlpp-2.40.1.ebuild 798 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. GCONF_DEBUG="no"
  5. GNOME_ORG_MODULE="${PN/pp/++}"
  6. inherit gnome2 multilib-minimal
  7. DESCRIPTION="C++ wrapper for the libxml2 XML parser library"
  8. HOMEPAGE="http://libxmlplusplus.sourceforge.net/"
  9. LICENSE="LGPL-2.1"
  10. SLOT="2.6"
  11. KEYWORDS="~alpha amd64 ~arm hppa ~ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
  12. IUSE="doc"
  13. RDEPEND="
  14. >=dev-libs/libxml2-2.7.7[${MULTILIB_USEDEP}]
  15. >=dev-cpp/glibmm-2.32[${MULTILIB_USEDEP}]
  16. "
  17. DEPEND="${RDEPEND}
  18. virtual/pkgconfig
  19. "
  20. multilib_src_prepare() {
  21. gnome2_src_prepare
  22. }
  23. multilib_src_configure() {
  24. ECONF_SOURCE="${S}" gnome2_src_configure \
  25. $(use_enable doc documentation)
  26. }
  27. multilib_src_install() {
  28. gnome2_src_install
  29. }