libxmlpp-3.0.1.ebuild 799 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. GNOME_ORG_MODULE="${PN/pp/++}"
  5. inherit gnome2 multilib-minimal
  6. DESCRIPTION="C++ wrapper for the libxml2 XML parser library"
  7. HOMEPAGE="http://libxmlplusplus.sourceforge.net/"
  8. LICENSE="LGPL-2.1"
  9. SLOT="3.0"
  10. KEYWORDS="~alpha amd64 ~arm hppa ~ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
  11. IUSE="doc"
  12. RDEPEND="
  13. >=dev-libs/libxml2-2.7.7[${MULTILIB_USEDEP}]
  14. >=dev-cpp/glibmm-2.32[${MULTILIB_USEDEP}]
  15. "
  16. DEPEND="${RDEPEND}
  17. virtual/pkgconfig[${MULTILIB_USEDEP}]
  18. "
  19. multilib_src_prepare() {
  20. gnome2_src_prepare
  21. }
  22. multilib_src_configure() {
  23. ECONF_SOURCE="${S}" gnome2_src_configure \
  24. $(use_enable doc documentation)
  25. }
  26. multilib_src_install() {
  27. gnome2_src_install
  28. }