pngpp-0.2.9.ebuild 669 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. MY_P=${P/pp/++}
  5. DESCRIPTION="A simple but powerful C++ interface to libpng"
  6. HOMEPAGE="http://www.nongnu.org/pngpp/"
  7. SRC_URI="mirror://nongnu/${PN}/${MY_P}.tar.gz"
  8. LICENSE="BSD"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE=""
  12. RDEPEND="media-libs/libpng:0"
  13. DEPEND=""
  14. S=${WORKDIR}/${MY_P}
  15. PATCHES=( "${FILESDIR}"/${PN}-0.2.9-DESTDIR.patch )
  16. src_compile() { :; }
  17. src_test() { :; }
  18. src_install() {
  19. emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install-headers
  20. einstalldocs
  21. docinto examples
  22. dodoc example/*.cpp
  23. docompress -x /usr/share/doc/${PF}/examples
  24. }