yaml-cpp-0.5.1.ebuild 680 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit cmake-utils
  5. DESCRIPTION="A YAML parser and emitter in C++"
  6. HOMEPAGE="https://github.com/jbeder/yaml-cpp"
  7. SRC_URI="https://${PN}.googlecode.com/files/${P}.tar.gz"
  8. LICENSE="MIT"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~arm ~hppa ~ppc ppc64 x86 ~amd64-linux ~x86-linux"
  11. IUSE=""
  12. DEPEND=">=dev-libs/boost-1.49.0-r2"
  13. RDEPEND="${DEPEND}"
  14. src_prepare() {
  15. sed -i \
  16. -e 's:INCLUDE_INSTALL_ROOT_DIR:INCLUDE_INSTALL_DIR:g' \
  17. yaml-cpp.pc.cmake || die
  18. cmake-utils_src_prepare
  19. }
  20. src_configure() {
  21. local mycmakeargs=(
  22. -DBUILD_SHARED_LIBS=ON
  23. )
  24. cmake-utils_src_configure
  25. }