gqlplus-1.16.ebuild 752 B

1234567891011121314151617181920212223242526272829
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools
  5. DESCRIPTION="a front-end for Oracle program sqlplus with command-line editing"
  6. HOMEPAGE="https://sourceforge.net/projects/gqlplus/"
  7. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~amd64-linux ~x64-macos"
  11. IUSE=""
  12. DEPEND="sys-libs/readline:*"
  13. RDEPEND="${DEPEND}"
  14. src_prepare() {
  15. # don't use packaged readline and old version containing it
  16. rm -Rf readline gqlplus-1.15
  17. # maintainer can't seem to get versioning right
  18. sed -i '/^#define VERSION/s/"[^"]\+"/"'"${PV}"'"/' gqlplus.c || die
  19. sed -i '/^AC_INIT/s/\[[1-9.]\+\]/['"${PV}"']/' configure.ac || die
  20. eautoreconf
  21. }