123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657 |
- # Copyright 1999-2011 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI=4
- inherit eutils toolchain-funcs
- DESCRIPTION="MySQL UDF to write to log files"
- HOMEPAGE="http://www.mysqludf.org/lib_mysqludf_log/"
- SRC_URI="http://www.mysqludf.org/${PN}/${PN}_${PV}.tar.gz"
- LICENSE="LGPL-2.1"
- SLOT="0"
- KEYWORDS="~amd64 ~x86"
- IUSE=""
- DEPEND=">=virtual/mysql-5.1"
- RDEPEND="${DEPEND}"
- S="${WORKDIR}"
- # compile helper
- _compile() {
- local CC="$(tc-getCC)"
- echo "${CC} ${@}" && "${CC}" "${@}"
- }
- pkg_setup() {
- MYSQL_PLUGINDIR="$(mysql_config --plugindir)"
- MYSQL_INCLUDE="$(mysql_config --include)"
- }
- src_prepare() {
- epatch "${FILESDIR}/${PN}-warnings.patch"
- }
- src_compile() {
- _compile ${CFLAGS} -Wall -fPIC ${MYSQL_INCLUDE} \
- -shared ${LDFLAGS} -o ${PN}.so ${PN}.c
- }
- src_install() {
- exeinto "${MYSQL_PLUGINDIR}"
- doexe ${PN}.so
- dodoc ${PN}.sql
- }
- pkg_postinst() {
- elog
- elog "Please have a look at the documentation, how to"
- elog "enable/disable the UDF functions of ${PN}."
- elog
- elog "The documentation is located here:"
- elog "/usr/share/doc/${PF}"
- elog
- }
|