libiodbc-3.52.12.ebuild 1.6 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit autotools multilib-minimal
  5. MY_PN="iODBC"
  6. DESCRIPTION="ODBC Interface for Linux"
  7. HOMEPAGE="http://www.iodbc.org/"
  8. SRC_URI="https://github.com/openlink/${MY_PN}/archive/v${PV}.zip -> ${P}.zip"
  9. KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
  10. LICENSE="|| ( LGPL-2 BSD )"
  11. SLOT="0"
  12. IUSE="gtk"
  13. RDEPEND="gtk? ( x11-libs/gtk+:2[${MULTILIB_USEDEP}] )"
  14. DEPEND="${RDEPEND}"
  15. DOCS=( AUTHORS NEWS README )
  16. S="${WORKDIR}/${MY_PN}-${PV}"
  17. MULTILIB_CHOST_TOOLS=( /usr/bin/iodbc-config )
  18. PATCHES=(
  19. "${FILESDIR}"/libiodbc-3.52.12-multilib.patch
  20. "${FILESDIR}"/libiodbc-3.52.7-debian_bug501100.patch
  21. "${FILESDIR}"/libiodbc-3.52.7-debian_bug508480.patch
  22. "${FILESDIR}"/libiodbc-3.52.7-unicode_includes.patch
  23. "${FILESDIR}"/fix-runpaths-r1.patch
  24. )
  25. src_prepare() {
  26. default
  27. sed -i.orig \
  28. -e '/^cd "$PREFIX"/,/^esac/d' \
  29. iodbc/install_libodbc.sh || die "sed failed"
  30. # Without this, automake dies. It's what upstream's autogen.sh does.
  31. touch ChangeLog || die "failed to create empty ChangeLog"
  32. eautoreconf
  33. }
  34. multilib_src_configure() {
  35. ECONF_SOURCE="${S}" \
  36. econf \
  37. --disable-static \
  38. --enable-odbc3 \
  39. --enable-pthreads \
  40. --with-layout=gentoo \
  41. --with-iodbc-inidir=yes \
  42. $(use_enable gtk gui)
  43. }
  44. multilib_src_install_all() {
  45. einstalldocs
  46. prune_libtool_files
  47. # Install lintian overrides
  48. insinto /usr/share/lintian/overrides
  49. newins debian/iodbc.lintian-overrides iodbc
  50. newins debian/libiodbc2.lintian-overrides libiodbc2
  51. }