lmdb++-0.9.14.0.ebuild 518 B

123456789101112131415161718192021222324
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. MY_P="${P/lmdb++/lmdbxx}"
  5. S="${WORKDIR}/${MY_P}"
  6. DESCRIPTION="C++11 wrapper for the LMDB database library"
  7. HOMEPAGE="http://lmdbxx.sourceforge.net/"
  8. SRC_URI="mirror://sourceforge/lmdbxx/${PV}/${MY_P}.tar.gz"
  9. LICENSE="public-domain"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE=""
  13. RDEPEND="dev-db/lmdb"
  14. src_install() {
  15. emake PREFIX="${D}/usr" install
  16. dodoc AUTHORS CREDITS INSTALL README TODO UNLICENSE
  17. }