mydumper-0.6.2.ebuild 923 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit cmake-utils versionator
  5. DESCRIPTION="A high-performance multi-threaded backup toolset for MySQL and Drizzle"
  6. HOMEPAGE="https://launchpad.net/mydumper"
  7. SRC_URI="https://launchpad.net/mydumper/$(get_version_component_range 1-2)/${PV}/+download/${P}.tar.gz"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="doc"
  12. RDEPEND="dev-libs/libpcre
  13. virtual/mysql
  14. dev-libs/glib:2"
  15. DEPEND="${RDEPEND}
  16. virtual/pkgconfig
  17. doc? ( <dev-python/sphinx-1.3 )"
  18. DOCS=( README )
  19. src_prepare() {
  20. # respect user cflags; do not expand ${CMAKE_C_FLAGS} (!)
  21. sed -i -e 's:-Werror -O3 -g:${CMAKE_C_FLAGS}:' CMakeLists.txt
  22. # fix doc install path
  23. sed -i -e "s:share/doc/mydumper:share/doc/${PF}:" docs/CMakeLists.txt
  24. }
  25. src_configure() {
  26. mycmakeargs=( $(cmake-utils_use doc BUILD_DOCS) )
  27. cmake-utils_src_configure
  28. }