mysql++-3.2.1.ebuild 901 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit eutils
  5. DESCRIPTION="C++ API interface to the MySQL database"
  6. HOMEPAGE="http://tangentsoft.net/mysql++/"
  7. SRC_URI="http://www.tangentsoft.net/mysql++/releases/${P}.tar.gz"
  8. LICENSE="LGPL-2"
  9. SLOT="0/3"
  10. KEYWORDS="alpha amd64 hppa ~mips ppc sparc x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
  11. IUSE=""
  12. RDEPEND=">=virtual/mysql-4.0"
  13. DEPEND="${RDEPEND}"
  14. src_prepare() {
  15. epatch "${FILESDIR}/${P}-gold.patch"
  16. epatch_user
  17. sed -i -e "s/mysqlclient_r/mysqlclient/" "${S}/configure" || die
  18. }
  19. src_configure() {
  20. local myconf="--enable-thread-check --with-mysql=${EPREFIX}/usr"
  21. econf ${myconf}
  22. }
  23. src_install() {
  24. default
  25. # install the docs and HTML pages
  26. dodoc CREDITS* HACKERS.txt Wishlist doc/ssqls-pretty
  27. dodoc -r doc/pdf/ doc/refman/ doc/userman/
  28. dohtml -r doc/html/
  29. }