mysql++-3.2.2.ebuild 853 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit eutils
  5. DESCRIPTION="C++ API interface to the MySQL database"
  6. HOMEPAGE="http://tangentsoft.net/mysql++/"
  7. SRC_URI="http://www.tangentsoft.net/mysql++/releases/${P}.tar.gz"
  8. LICENSE="LGPL-2"
  9. SLOT="0/3"
  10. KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
  11. IUSE=""
  12. RDEPEND="virtual/libmysqlclient:="
  13. DEPEND="${RDEPEND}"
  14. src_prepare() {
  15. epatch "${FILESDIR}/${PN}-3.2.1-gold.patch"
  16. epatch_user
  17. }
  18. src_configure() {
  19. local myconf="--enable-thread-check --with-mysql=${EPREFIX}/usr"
  20. econf ${myconf}
  21. }
  22. src_install() {
  23. default
  24. # install the docs and HTML pages
  25. dodoc CREDITS* HACKERS.txt Wishlist doc/ssqls-pretty
  26. dodoc -r doc/pdf/ doc/refman/ doc/userman/
  27. dohtml -r doc/html/
  28. }