mysql++-3.2.3.ebuild 1.0 KB

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit eutils
  5. DESCRIPTION="C++ API interface to the MySQL database"
  6. HOMEPAGE="http://tangentsoft.net/mysql++/"
  7. SRC_URI="http://www.tangentsoft.net/mysql++/releases/${P}.tar.gz"
  8. LICENSE="LGPL-2"
  9. SLOT="0/3"
  10. KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
  11. IUSE="doc"
  12. RDEPEND="virtual/libmysqlclient:="
  13. DEPEND="${RDEPEND}"
  14. DOCS=( CREDITS.txt HACKERS.txt Wishlist doc/ssqls-pretty )
  15. src_prepare() {
  16. eapply "${FILESDIR}/${PN}-3.2.1-gold.patch"
  17. eapply_user
  18. # Current MySQL libraries are always with threads and slowly being removed
  19. sed -i -e "s/mysqlclient_r/mysqlclient/" "${S}/configure" || die
  20. rm "${S}/doc/"README-*-RPM.txt || die
  21. }
  22. src_configure() {
  23. local myconf="--enable-thread-check --with-mysql=${EPREFIX}/usr"
  24. econf ${myconf}
  25. }
  26. src_install() {
  27. default
  28. # install the docs and HTML pages
  29. use doc && dodoc -r doc/pdf/ doc/refman/ doc/userman/ doc/html/
  30. }