mysql-super-smack-1.3-r3.ebuild 1.5 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. WANT_AUTOMAKE="1.13"
  5. AUTOTOOLS_AUTORECONF="YES"
  6. #AUTOTOOLS_IN_SOURCE_BUILD="YES"
  7. inherit eutils autotools-utils
  8. MY_PN="super-smack"
  9. MY_P="${MY_PN}-${PV}"
  10. DESCRIPTION="Benchmarking, stress testing, and load generation tool for MySQL & PostGreSQL"
  11. HOMEPAGE="http://vegan.net/tony/supersmack/"
  12. SRC_URI="http://vegan.net/tony/supersmack/${MY_P}.tar.gz"
  13. LICENSE="GPL-2"
  14. SLOT="0"
  15. KEYWORDS="amd64 ~ppc x86"
  16. IUSE="+mysql postgres"
  17. REQUIRED_USE="|| ( mysql postgres )"
  18. DEPEND="mysql? ( virtual/mysql )
  19. postgres? ( dev-db/postgresql[server] )"
  20. RDEPEND="${DEPEND}"
  21. S="${WORKDIR}/${MY_P}"
  22. PATCHES=(
  23. "${FILESDIR}"/${PN}-1.2.destdir.patch
  24. "${FILESDIR}"/${PN}-1.3.amd64.patch
  25. "${FILESDIR}"/${PN}-1.3.gcc4.3.patch
  26. "${FILESDIR}"/${PN}-1.3-gen-data.patch
  27. "${FILESDIR}"/${PN}-1.3-automake-1.13.patch
  28. )
  29. DOCS=( CHANGES INSTALL MANUAL README TUTORIAL )
  30. src_prepare() {
  31. # Clean up files so eautoreconf does not pick up any
  32. # deprecated autotools macros.
  33. rm acinclude.m4 aclocal.m4 acconfig.h config.status config.h || die
  34. mv configure.in configure.ac || die
  35. autotools-utils_src_prepare
  36. }
  37. src_configure() {
  38. local myeconfargs=(
  39. $(usex mysql --with-mysql "")
  40. $(usex postgres --with-pgsql "")
  41. --with-datadir=/var/tmp/${MY_PN}
  42. --with-smacks-dir=/usr/share/${MY_PN}
  43. )
  44. autotools-utils_src_configure
  45. }
  46. pkg_postinst() {
  47. elog "The gen-data binary is now installed as super-smack-gen-data"
  48. }