phppgadmin-9999.ebuild 947 B

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. # Copyright 1999-2011 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="2"
  4. inherit webapp git-2
  5. DESCRIPTION="Web-based administration for Postgres database in php"
  6. HOMEPAGE="http://phppgadmin.sourceforge.net/"
  7. EGIT_REPO_URI="git://github.com/xzilla/${PN}.git
  8. https://github.com/xzilla/${PN}.git"
  9. LICENSE="GPL-2"
  10. KEYWORDS=""
  11. IUSE=""
  12. RDEPEND="
  13. || (
  14. <dev-lang/php-5.3[pcre]
  15. >=dev-lang/php-5.3
  16. )
  17. dev-lang/php[postgres,session]
  18. "
  19. pkg_setup() {
  20. webapp_pkg_setup
  21. }
  22. src_install() {
  23. webapp_src_preinst
  24. local doc
  25. local docs="CREDITS DEVELOPERS FAQ HISTORY INSTALL TODO TRANSLATORS"
  26. dodoc ${docs}
  27. mv conf/config.inc.php-dist conf/config.inc.php
  28. cp -r * "${D}"${MY_HTDOCSDIR}
  29. for doc in ${docs} INSTALL LICENSE; do
  30. rm -f "${D}"${MY_HTDOCSDIR}/${doc}
  31. done
  32. webapp_configfile ${MY_HTDOCSDIR}/conf/config.inc.php
  33. webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
  34. webapp_src_install
  35. }