spatialite-tools-4.3.0-r1.ebuild 666 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. DESCRIPTION="A collection of CLI tools supporting SpatiaLite"
  5. HOMEPAGE="https://www.gaia-gis.it/spatialite"
  6. SRC_URI="https://www.gaia-gis.it/gaia-sins/${PN}-sources/${P}.tar.gz"
  7. LICENSE="MPL-1.1"
  8. SLOT="0"
  9. KEYWORDS="~amd64 ~x86"
  10. IUSE="readline"
  11. RDEPEND="
  12. dev-db/sqlite:3[extensions(+)]
  13. >=dev-db/spatialite-3.0.1[geos,xls]
  14. dev-libs/expat
  15. dev-libs/libxml2
  16. sci-geosciences/readosm
  17. sci-libs/geos
  18. sci-libs/proj
  19. readline? (
  20. sys-libs/ncurses:=
  21. sys-libs/readline:=
  22. )
  23. "
  24. DEPEND="${RDEPEND}"
  25. src_configure() {
  26. econf \
  27. $(use_enable readline)
  28. }