spatialite-4.3.0a.ebuild 1.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. MY_PN="lib${PN}"
  5. MY_P="${MY_PN}-${PV}"
  6. DESCRIPTION="A complete Spatial DBMS in a nutshell built upon sqlite"
  7. HOMEPAGE="https://www.gaia-gis.it/gaia-sins/"
  8. SRC_URI="https://www.gaia-gis.it/gaia-sins/${MY_PN}-sources/${MY_P}.tar.gz"
  9. LICENSE="MPL-1.1"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
  12. IUSE="+geos iconv +proj test +xls +xml"
  13. RDEPEND="
  14. >=dev-db/sqlite-3.7.5:3[extensions(+)]
  15. sys-libs/zlib
  16. geos? ( >=sci-libs/geos-3.4 )
  17. proj? ( sci-libs/proj )
  18. xls? ( dev-libs/freexl )
  19. xml? ( dev-libs/libxml2 )
  20. "
  21. DEPEND="${RDEPEND}"
  22. REQUIRED_USE="test? ( iconv )"
  23. S="${WORKDIR}/${MY_P}"
  24. src_configure() {
  25. econf \
  26. --disable-examples \
  27. --disable-static \
  28. --enable-epsg \
  29. --enable-geocallbacks \
  30. $(use_enable geos) \
  31. $(use_enable geos geosadvanced) \
  32. $(use_enable iconv) \
  33. $(use_enable proj) \
  34. $(use_enable xls freexl) \
  35. $(use_enable xml libxml2)
  36. }
  37. src_install() {
  38. default
  39. find "${D}" -name '*.la' -delete || die
  40. }