sqlcipher-3.3.0.ebuild 971 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. AUTOTOOLS_AUTORECONF=1
  5. inherit autotools-multilib flag-o-matic
  6. DESCRIPTION="Full Database Encryption for SQLite"
  7. HOMEPAGE="http://sqlcipher.net/"
  8. SRC_URI="https://github.com/sqlcipher/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  9. LICENSE="BSD"
  10. SLOT="0"
  11. KEYWORDS="amd64 x86"
  12. IUSE="readline static-libs tcl test"
  13. # Tcl is always needed by buildsystem
  14. RDEPEND="dev-libs/openssl:0[${MULTILIB_USEDEP}]
  15. readline? ( sys-libs/readline:0=[${MULTILIB_USEDEP}] )
  16. tcl? ( dev-lang/tcl:=[${MULTILIB_USEDEP}] )"
  17. DEPEND="${RDEPEND}
  18. dev-lang/tcl"
  19. # Testsuite requires compilation with TCL, bug #582584
  20. REQUIRED_USE="test? ( tcl )"
  21. src_prepare() {
  22. append-cflags -DSQLITE_HAS_CODEC
  23. autotools-multilib_src_prepare
  24. }
  25. src_configure()
  26. {
  27. local myeconfargs=(
  28. --enable-tempstore=yes
  29. $(use_enable readline)
  30. $(use_enable tcl)
  31. )
  32. autotools-multilib_src_configure
  33. }