sqliteodbc-0.96.ebuild 800 B

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit eutils multilib toolchain-funcs
  5. DESCRIPTION="ODBC driver to access local SQLite database files"
  6. HOMEPAGE="http://www.ch-werner.de/sqliteodbc/"
  7. SRC_URI="http://www.ch-werner.de/sqliteodbc/${P}.tar.gz"
  8. LICENSE="BSD"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~arm ppc x86"
  11. IUSE=""
  12. DEPEND=">=dev-db/sqlite-3.6
  13. || (
  14. >=dev-db/unixODBC-2.2
  15. >=dev-db/libiodbc-3.5
  16. )"
  17. RDEPEND="${DEPEND}"
  18. pkg_setup() {
  19. tc-export CC
  20. }
  21. src_prepare() {
  22. epatch "${FILESDIR}/${PN}-0.93-respect_LDFLAGS.patch"
  23. }
  24. src_configure() {
  25. econf --disable-static
  26. }
  27. src_install() {
  28. dodir "/usr/$(get_libdir)"
  29. einstall
  30. find "${D}" -name '*.la' -exec rm -f {} + || die "la file removal failed"
  31. dodoc ChangeLog README
  32. }