gputils-1.5.0.ebuild 632 B

1234567891011121314151617181920212223242526272829
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit toolchain-funcs
  5. DESCRIPTION="Tools including assembler, linker and librarian for PIC microcontrollers"
  6. HOMEPAGE="http://gputils.sourceforge.net/"
  7. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
  11. IUSE=""
  12. src_configure() {
  13. tc-ld-disable-gold #369291
  14. # Their configure script tries to do funky things with default
  15. # compiler selection. Force our own defaults instead.
  16. tc-export CC
  17. default
  18. }
  19. src_install() {
  20. default
  21. dodoc doc/gputils.pdf
  22. }