pista-0.70.ebuild 682 B

1234567891011121314151617181920212223242526
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. DESCRIPTION="Commandline-driven interface to PICSTART+ PIC programmer"
  4. HOMEPAGE="http://gatling.ikk.sztaki.hu/~kissg/pd/pista/pista.html"
  5. SRC_URI="ftp://gatling.ikk.sztaki.hu/pub/pic/pista/${P}.tar.gz
  6. http://pista.choup.net/pub/pic/pista/${P}.tar.gz"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="~amd64 ~ppc x86"
  10. IUSE=""
  11. RDEPEND="dev-lang/perl
  12. dev-perl/TermReadKey"
  13. src_compile() {
  14. perl Makefile.PL PREFIX=/usr || die "Running Makefile.PL failed"
  15. emake || die "make failed"
  16. }
  17. src_install() {
  18. emake install DESTDIR=${D} || die
  19. dodoc README Changes Copyright doc/pista.html
  20. }