powersoftplus-libftdi-0.1.8-r1.ebuild 749 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit multilib toolchain-funcs
  5. MY_PN="${PN/-libftdi/}"
  6. MY_P="${MY_PN}-${PV}"
  7. TABFILE="libd2xx_table.so"
  8. TABFILEDIR="libftdi/lib_table"
  9. DESCRIPTION="Library which includes a table of VIDs and PIDs of Ever UPS devices"
  10. HOMEPAGE="http://www.ever.com.pl"
  11. SRC_URI="http://www.ever.com.pl/pl/pliki/${MY_P}-x86.tar.gz"
  12. LICENSE="LGPL-2"
  13. SLOT="0"
  14. KEYWORDS="~x86"
  15. IUSE=""
  16. DEPEND=""
  17. RDEPEND="${DEPEND}"
  18. S="${WORKDIR}/${MY_P}"
  19. src_compile() {
  20. cd "${TABFILEDIR}"
  21. # Wipe out precompiled binary
  22. emake clean
  23. emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
  24. }
  25. src_install() {
  26. ftditabfile="${TABFILEDIR}/${TABFILE}"
  27. dolib.so ${ftditabfile}
  28. }